在 GNOME 中为 Emacs 交换 Caps 与左 Ctrl 键
evince 的变化

gentoo + gnome overlay -> gnome-2.31.90

Garfileo posted @ 2010年9月19日 02:31 in Linux 的世界 with tags gnome , 2703 阅读

gnome 2.31.90 是 gentoo gnome overlay 里的版本号,已经很接近 2.32 了。虽然 gnome 项目将 3.0 的发布推迟到明年的春天,不过我还是津津于当前版本号增加 0.2。

若要安装 gnome overlay 中的 gnome 2.31.90,需要对以下软件包解除屏蔽(至少在我这里是这样):

### gnome 2.32
gnome-base/gnome-desktop
gnome-base/nautilus
gnome-extra/yelp
gnome-base/gnome-settings-daemon
gnome-base/libgnomekbd
gnome-extra/yelp-xsl
gnome-base/gconf
dev-libs/glib
x11-libs/gtk+
x11-libs/gdk-pixbuf
x11-libs/cairo
net-libs/webkit-gtk
dev-python/pygobject
gnome-base/librsvg

随后,我还要再试验一下 gnome-shell。

gnome overlay 中的 gnome-shell,目前版本是 2.31.5。在我这里,需要在 /etc/portage/profile/package.use.mask 文件中写入以下解除 USE 屏蔽的包:

media-libs/clutter -introspection
x11-wm/mutter -introspection -gtk3
dev-libs/json-glib -introspection
x11-libs/gdk-pixbuf -introspection
gnome-base/gconf    -introspection
x11-libs/pango -introspection
x11-libs/gtk+ -introspection
dev-libs/atk -introspection
media-libs/libcanberra -gtk3
dev-libs/libgee -introspection

解除了上述包的 USE 屏蔽之后,需要在 /etc/portage/package.use 中开启对应的 USE。

除此以外,要注意的是 libgee 0.5.3 版本可能会编译不过去,是因它的 GIR 文件出错导致的,安装 0.5.2 版本即可。

转载时,希望不要链接文中图片,另外请保留本文原始出处:http://garfileo.is-programmer.com


登录 *


loading captcha image...
(输入验证码)
or Ctrl+Enter